>I would suggest we have two type parameters: parent-type and
>aggregate-type. The parent-type would replace the type we have now and
>label the type of the parent part pointed to by the start parameter. The
>values for parent-type parameter are clearly the value we are using now for
>the type parameter.
How about still using "type" and adding "aggregate-type". One or
both of which must be present in a multipart/related. I don't mind
changing my code but I do mind unnecessary changes in field names.
Other than that I think Laurence's idea is great. Let me suggest that
we have at least one registered aggregate-type or a concrete example
to show people how it should be used.
P.S. I was on the Montreal editing team and still volunteer to help
out rereading any draft of this working group.
Emissary Development Group